## JMARS

### Basic Layers

<table>
<thead>
<tr>
<th>Layer</th>
<th>page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lat/Lon Grid</td>
<td>2</td>
</tr>
<tr>
<td>Map Scalebar</td>
<td>4</td>
</tr>
<tr>
<td>Nomenclature</td>
<td>6</td>
</tr>
<tr>
<td>Crater Counting</td>
<td>14</td>
</tr>
<tr>
<td>3D</td>
<td>41</td>
</tr>
<tr>
<td>Shape</td>
<td>52</td>
</tr>
<tr>
<td>Mosaics</td>
<td>65</td>
</tr>
<tr>
<td>Map</td>
<td>71</td>
</tr>
</tbody>
</table>
Lat/Lon Grid Layer

The Latitude/Longitude Grid Layer, which is available in all releases of JMARS, draws latitude and longitude lines in the Viewing Window and allows users to measure distances.
Display a Latitude/Longitude Grid

1. **Open the Lat/Lon Grid Layer**: The Lat/Lon Grid is one of two default layers in JMARS that will open automatically whenever JMARS is started.
   - If you need to re-open the Lat/Lon Grid Layer after closing it, go to the Layer Manager, choose "Add New Layer" -> "Lat/Lon Grid"
2. **Edit the Default Grid Settings**: To change any of the layer's default settings (ie: line spacing, line color, etc), double click on the "Lat/Lon Grid" tab in the Layer Manager to access the focus panel.
3. **Select Major Line Frequency**: JMARS defaults to placing major latitude and longitude lines at 10 degree intervals, but this can be changed by editing the "Major Lines" box. Users can also chose whether or not the major lines are displayed in the Main and Panning Views by clicking the appropriate checkboxes.
4. **Select Major Line Color**: The default color for the major lines is black, but it can be changed by clicking on the black color box and choosing a new color.
5. **Select Minor Line Frequency**: JMARS defaults to placing minor latitude and longitude lines every 2 degrees, although it does not automatically display them in either the Main or Planning Views. Users can add the minor lines to either view by clicking on the appropriate display checkbox.
6. **Select Minor Line Color**: The default color for the minor lines is gray, but it can be changed by clicking on the gray color box and choosing a new color.
Map Scalebar Layer

The Map Scalebar Layer, which is available in all releases of JMARS, displays a scalebar in the Main View that automatically shows the correct scale for the map being viewed. This layer is extremely helpful when taking screenshots from JMARS.

Display the Map Scalebar

1. *Open the Map Scalebar Layer:* In the Layer Manager, choose "Add New Layer" -> "Map Scalebar"
   o The scalebar will appear in the lower right-hand corner of the Main View.
2. *Change the Location of the Scalebar:* Users can change the location of the scalebar within the Main View by left-clicking and dragging it to a new location.

![Map Scalebar Layer interface in JMARS](image-url)
3. **Change the Appearance of the Scalebar**: The scalebar is opened with its default display settings. To change the appearance of the scalebar, click on the "Map Scalebar" tab in the Layer Manager to access the focus panel.

   a. **Label Units**: Users can choose from either Metric (km,m) or Imperial (mi,ft) units.

   b. **Label Font**: The font, font color, font outline color and font size can all be changed by clicking on the "Choose Font..." button.

   c. **Label Alignment**: The distance label under the scalebar can be justified, relative to the ruler, by clicking on the appropriate checkbox.

   d. **Ruler Width**: The horizontal width of the ruler can be set as a percentage of the Main View width.

   e. **Ruler Color**: The color of the scalebar can be changed by clicking on the black box and choosing another color.

   f. **Scalebar Tickmarks**: Using the "Tick Count" slider, users can change the number of tickmarks displayed on the scalebar.

   g. **Tickmark Colors**: The color of the scalebar tickmarks can be changed independently of the scalebar color by clicking on the black box and choosing another color.
Nomenclature Layer

The Nomenclature Layer displays the names and locations of all the named features on Mars. This data has been provided by the U.S. Geological Survey's Astrogeology Research Program. The Nomenclature Layer is available in all JMARS releases.

Displaying the Nomenclature Layer

1. Open the Nomenclature Layer: In the Layer Manager, chose "Add New Layer" -> "Nomenclature
Add a New Layer

Select Category:

Home

Subcategories

Map Cartography (2)

Lat/Lon Grid

Map Scalebar

Other (5)

3D Layer

Custom Shape Layer

Nomenclature

Crater Counting

Mosaic Outlines

Close

Dock Me
The Nomenclature Layer will open with its default settings, which will probably need to be changed in order to see the features you are interested in.

2. Display Points: On the Nomenclature Layer’s focus panel in the "Points" section, check whether the feature points should be displayed in the Main View, Panning View or both.

3. Select Point Color: The default color of the points is red, but if a colorized map is being used a different color may be more visible. Click on the red box to select a different color.

4. Display Labels: Under the Labels section, check whether the feature name labels should be displayed in the Main View, Panning View or both.

5. Display Label Tooltips: With the tooltips enabled, mousing-over the feature names will provide the feature name, feature type, coordinates and the meaning of the name in a mouse tooltip box.

6. Select Landmark Type: Highlighting a type of feature in the scroll list in the "Selected Landmark Types" section will only display that type of feature in the Viewing Window.
   - Users can display all the feature types by clicking the "Select All" button.
   - A glossary of the landmark types is available below.

---

**Locate a Specific Feature**

1. Select Landmark Type: In the "Navigation" section of the focus panel, chose a type of feature from the "Landmark Type" drop-down menu.
   - A glossary of the landmark types is available below.

2. Select Landmark: Select a specific landmark from under the "Landmark" drop-down menu.
   - The options in this menu will change depending on what "Landmark Type" was chosen.

3. Locate Landmark: Click the "Goto" button, which will recenter the Viewing Window on the specified landmark.
Martian Landmark Types

These features are created by variations in the amount of sunlight reflected by the Martian surface due to surface material. A perfectly white surface would have an albedo of 1.0 while a perfectly black surface would have an albedo of 0. These were the only features that early astronomers were able to identify on the surface of Mars.

<table>
<thead>
<tr>
<th>Features</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catena</td>
<td>A linear string of craters produced by a series of impacts, usually caused by a single object (meteor, asteroid, comet, etc) that broke apart shortly before impact, much like Comet Shoemaker-Levy 9 did before it hit Jupiter. Alternately, it can be a string of circular collapse pits in a subsurface lava tube that merely resembles a string of craters. The context is usually sufficient to determine how a particular catena formed.</td>
</tr>
<tr>
<td>Cavus</td>
<td>A crater-like, irregularly shaped depression that was not created by an impact.</td>
</tr>
<tr>
<td>Chaos</td>
<td>An area of jumbled or hummocky terrain that is thought to be the result of a sudden release of subsurface water, which then caused the terrain above it to collapse in an irregular pattern.</td>
</tr>
<tr>
<td>Chasma</td>
<td>A large canyon, depression or trough with steep sides.</td>
</tr>
<tr>
<td>Collis</td>
<td>A small hill or knoll. A group is referred to as a colles.</td>
</tr>
<tr>
<td>Crater</td>
<td>A circular depression created by an impact. Newer impacts are often surrounded by an ejecta blanket. Craters can be sub-divided into: simple, complex, central peak basin, peak ring basin, multi-ring basin and rampart craters.</td>
</tr>
<tr>
<td>Dorsum</td>
<td>An elongated elevated feature (longer than it is wide) similar to a ridge on Earth.</td>
</tr>
<tr>
<td>Fluctus</td>
<td>A flow-like feature. Only one such example exists on Mars - Galaxias Fluctus. The term was originally used to describe features on Jupiter's moon Io that look like flowing terrain. In Latin, fluctus means either &quot;wave&quot; or &quot;billow&quot;.</td>
</tr>
<tr>
<td>Fossa</td>
<td>A long narrow linear depression that was is likely the result of faulting. On Mars, fossa often occur in groups which are referred to as &quot;fossae&quot;.</td>
</tr>
<tr>
<td>Labes</td>
<td>Features that are likely the result of a landslide. They usually appear as lobed deposits flowing from some common source.</td>
</tr>
<tr>
<td>Labyrinth</td>
<td>An area of intersecting linear depressions, canyons or valleys. The class example on Mars is Noctis Labyrinthus.</td>
</tr>
<tr>
<td><strong>Mensa</strong></td>
<td>An elevated area with a flat top and steep sides, similar to mesas in the American southwest.</td>
</tr>
<tr>
<td>-------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Mons</strong></td>
<td>A large, geographically-isolated mountain, as opposed to a chain of mountains (Montes). Most examples on Mars are volcanic in origin.</td>
</tr>
<tr>
<td><strong>Patera</strong></td>
<td>A complex or irregularly shaped crater with low-relief, scalloped edges and radiating channel-like features. Most are thought to be volcanic in origin and similar to low shield volcanoes on Earth.</td>
</tr>
<tr>
<td><strong>Planita</strong></td>
<td>A plain whose area is at a lower elevation than the surrounding terrain.</td>
</tr>
<tr>
<td><strong>Planum</strong></td>
<td>A relatively smooth and flat area that is higher than the surrounding terrain, similar to a plateau on Earth.</td>
</tr>
<tr>
<td><strong>Rupes</strong></td>
<td>A cliff or scarp that is straight and linear rather than sinuous.</td>
</tr>
<tr>
<td><strong>Scopulus</strong></td>
<td>A cliff or scarp that is irregular or lobate in appearance.</td>
</tr>
<tr>
<td><strong>Sulcus</strong></td>
<td>A feature that resembles a furrow or wrinkle, often found in groups referred to as &quot;sulci&quot;.</td>
</tr>
<tr>
<td><strong>Terra</strong></td>
<td>An extended region or landmass, often used in reference to parts of the southern highlands.</td>
</tr>
<tr>
<td><strong>Tholus</strong></td>
<td>An isolated, dome-shape small mountain or hill thought to be volcanic in origin.</td>
</tr>
<tr>
<td><strong>Undae</strong></td>
<td>An area of sand dunes that are very wave-like in appearance.</td>
</tr>
<tr>
<td><strong>Vallis</strong></td>
<td>A sinuous valley or canyon, usually fluvial in origin.</td>
</tr>
<tr>
<td><strong>Vastitas</strong></td>
<td>A large lowland plain. The only example on Mars is Vastitas Borealis, which surrounds the north polar cap.</td>
</tr>
</tbody>
</table>
Crater Counting Layer

The Crater Counting Layer allows users to mark craters and then output the locations, diameters and other associated data to shape files in various formats. This data can then be used for regional-scale studies or combined with similar data from multiple users to enable global-scale crater studies.
Marking Craters

1. *Open the Crater Counting Layer:* In the Layer Manager, click the "Add New Layer" button and select "Crater Counting".
2. **Select the Crater Counting Tab:** If the user double-clicks on the "The Crater Counting" layer, details and options for the layer appear.
3. *Choose a Crater to Mark:* Users should adjust the resolution (using the pull-down zoom menu at the top-right of the Main View) and pan around in the Main View as needed to find a crater they want to mark.
4. **Recenter the Map Projection:** In the Main View, choose "View" from the menu bar and then select "Recenter projection"
   - The Crater Counting layer will only draw circles. However, if users move too far away from the center of the current map projection, circular craters will appear increasingly non-circular. To ensure the correct diameter is being chosen, users should re-center the projection whenever they pan away from the last point they centered over. This is especially important as users move to higher latitudes.
5. *Set the Crater Diameter:* A semi-transparent black circle will appear under the mouse cursor in the Main View. Users can adjust the diameter using the center scrollwheel on their mouse.
o The default diameter increment is 1km.
o On most systems, each tick of the mouse scrollwheel equals ten increments.
o Holding shift will change each mouse scrollwheel tick to a single increment.
o The + or - keys will increment the same as the mouse scrollwheel.
o Holding the control key (Crtl) down while using the + or - keys will change to a single increment.
o Users can change the diameter increment step size in the "Settings" tab in the Crater Counting Layer's focus panel.
6. **Entering a Crater Marker:** Once the correct diameter has been selected, the marker can be entered into the "Crater Counting" Layer tab by clicking in the Main View. An entry for the marker will be added to the table in the "Craters" tab of the focus panel.
Marking Craters using the Three Point Method

In addition to marking craters using a variable radius circle, craters may be marked by clicking three points along the rim of the crater to be marked.

1. *Switch to Three Point Mode:* In the Main View, right click and choose "Crater mode", then select "Three point mode".

![Image of software interface demonstrating three point mode for crater marking]
2. *Mark a Crater:* Select a point along the rim of a crater to be marked. Left click with the mouse. A small red circle will appear where you clicked. Click two additional points along the rim of the crater. After the third click, the crater will be marked and an entry for the marker will be added to the table in the "Craters" tab of the "Crater Counting" focus panel.
Counting Craters within Parameters

Depending on the study being performed, it may be useful to automatically count how many craters fall within a given range of parameters. Users can perform basic searches by entering minimum and maximum values for Latitude, Longitude and Diameter at the bottom of the "Craters" tab in the Crater Counting Layer's focus panel. The number of marked craters matching the criteria will be output at the bottom of the tab.
Configuration for Exporting Crater Markers

The user has the option to filter the counted crater data that can be exported to a file. While the latitude, longitude, and diameter data are required for export, the user may choose to exclude notes (comments), colors, or their user id from the export file.

1. In the Craters tab of the focus panel, click "Config"
2. Check or uncheck any or all of the settings for "Color", "Note", or "User".
3. Click "OK" to accept the changes or "Cancel" to accept the defaults (all table columns are exported).
Saving (Exporting) Crater Markers

1. In the "Craters" tab of the focus panel, click "Export"
2. Choose a location to save the file, assign the file a name and set a file type (ESRI or CSV).
3. Click "Save"
Loading (Importing) Crater Markers

1. In the "Craters" tab of the focus panel, click "Import"
2. Choose a previously-created Crater Counting Layer shape file (ESRI or CSV) to load.
3. Click "Load"
Adjusting the Layer Settings

Under the "Settings" tab in the Crater Counting Layer's focus panel, users can change many of the layer's default settings.

1. *Change Marked Crater Color*: Users can choose from any of the colors available in the "New crater color:" pull-down menu.
2. *Change Crater Marking Circle Transparency*: The transparency of the circle markers can be adjusted using the "Fill Alpha:" slide bar.
3. **Manually Change New Crater Diameter:** By default, the starting diameter of a crater marker is the diameter of the last crater marker entered. If users want to manually change this value, they can do so using the "New crater diameter (meters):" input field.
   - Note: Be sure to enter values in meters and not in kilometers!
4. **Use a Default Crater Size**: Users may wish to use a default crater diameter for the next crater to be marked. For example, a user may wish to count 100 km diameter craters, but occasionally mark larger or smaller craters in the same marking session. In this case the user would set the crater diameter with the mouse scrollwheel or by entering a new crater diameter into the "New crater diameter (meters):" input field. Then while marking craters, if they decide to mark a larger or smaller crater, they would check the "Default crater size:" checkbox, either input a new crater diameter in the "New crater diameter (meters):" input field or select a new diameter with the mouse scrollwheel, and mark the larger or smaller crater. The "New crater diameter (meters):" input field would then be automatically reset to the value of "Default crater size:" for the next crater to be marked. The user may also manually enter the default crater diameter and then check the "Default Crater Size" checkbox.
   - Note: Be sure to enter values in meters and not in kilometers!
5. *Select the Outline Thickness of the Crater Marking Circle*: Users can choose to make the outline thickness of the crater marking circle be thinner or thicker by scrolling through the choices provided by the "Crater outline thickness:" selection field until the desired outline thickness is found.
6. Display the Crater Marking Diameter in the Main View: Users may wish to either display or hide the diameter of the next crater to be marked by checking or unchecking the "Visible circle diameter value" checkbox.
7. **Change Diameter Increment Size:** Users can choose from the standard diameter increments of 10km, 1km, 100m, 10m, 1m or they can specify their own.
8. **Selective Display of Filtered Craters:** Users may select which areas of the application will display filtered craters.
   - MainView
   - Panner
   - Table
Using the Colors Tab

Different circle colors can be used in the Main View to represent different types of craters (ie: preserved/modified/destroyed). Using the "Colors" tab in the Crater Counting Layer's focus panel, users can assign a note or value to each available color (ie: blue=preserved, green=modified, etc). Then, when users enter crater markers of those colors in the Main View, the Crater Counting Layer will not only record the location and diameter of the crater, but also the note that was assigned to all crater markers of that color. Those comments are preserved when the output files are imported/exported.
Using Colors in the Craters Tab

Crater marker colors can be changed on a crater-by-crater basis in the "Craters" tab of the Crater Counting Layer's focus panel. When changing crater marker colors using this method, the note (if any have been assigned) associated with the new crater color in the "Colors" tab will be automatically associated with the crater marker in the "Craters" tab.
### Import/Export Crater Data

<table>
<thead>
<tr>
<th>Center Lon</th>
<th>Center Lat</th>
<th>Diameter</th>
<th>Note</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>60.812</td>
<td>21.5370 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>65.562</td>
<td>22.812190 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>56.812</td>
<td>25.937140 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>54.75</td>
<td>26.75110 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>53.875</td>
<td>27.93770 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>49.375</td>
<td>22.550 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>51.938</td>
<td>22.550 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>51.5</td>
<td>24.31250 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>53.438</td>
<td>20.6250 km</td>
<td></td>
<td>Destroyed</td>
<td></td>
</tr>
<tr>
<td>52.437</td>
<td>19.550 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>55.188</td>
<td>17.375120 km</td>
<td></td>
<td>Destroyed</td>
<td></td>
</tr>
<tr>
<td>56.312</td>
<td>21.875120 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>64.062</td>
<td>16.875120 km</td>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>70.188</td>
<td>18.812120 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>55.625</td>
<td>-13.875460 km</td>
<td></td>
<td>Preserved</td>
<td></td>
</tr>
</tbody>
</table>

### Count Craters within Filter Parameters

- **Latitude**: 0 to 25
- **Longitude**: 50 to 75
- **Diameter (m)**: 0 to 50000000

**Matching Craters**: 10 of 15

### Crater Counting Options

Options include Import, Export, and Config.
## Crater Counting Options

### Import/Export Crater Data

<table>
<thead>
<tr>
<th>Center Lon</th>
<th>Center Lat</th>
<th>Diameter</th>
<th>Note</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>60.812</td>
<td>21.5370 km</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>65.562</td>
<td>22.812 km</td>
<td>190 km</td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>56.812</td>
<td>25.937 km</td>
<td>140 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>54.75</td>
<td>26.75 km</td>
<td>110 km</td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>53.875</td>
<td>27.937 km</td>
<td>70 km</td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>49.375</td>
<td>22.55 km</td>
<td>50 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>51.938</td>
<td>22.55 km</td>
<td>50 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>51.5</td>
<td>24.31 km</td>
<td>50 km</td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>53.438</td>
<td>22.06 km</td>
<td>50 km</td>
<td>Destroyed</td>
<td></td>
</tr>
<tr>
<td>52.437</td>
<td>19.55 km</td>
<td>50 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>55.188</td>
<td>17.37 km</td>
<td>120 km</td>
<td>Destroyed</td>
<td></td>
</tr>
<tr>
<td>56.312</td>
<td>21.87 km</td>
<td>120 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>64.062</td>
<td>16.87 km</td>
<td>120 km</td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td>70.188</td>
<td>18.81 km</td>
<td>120 km</td>
<td>Preserved</td>
<td></td>
</tr>
<tr>
<td>55.625</td>
<td>-13.87 km</td>
<td>460 km</td>
<td>Modified</td>
<td></td>
</tr>
</tbody>
</table>

### Count Craters within Filter Parameters

- **Latitude**: 0 to 25
- **Longitude**: 50 to 75
- **Diameter (m)**: 0 to 5000000

Matching Craters: 10 of 15
3D Layer

The 3D Layer is unlike many of the JMARS layers because it does not load any visual data into the Viewing Window. Instead, it opens a new window and displays a three-dimensional version of the scene in the Main View. This allows the user to observe the altitude of the terrain directly, instead of relying on the shadowing of the 2D maps to determine the height or depth of certain features. The 3D Layer is available in the THEMIS and Public releases of JMARS.

Navigating in the 3D Layer

1. *Display a Map in the Viewing Window*: Before loading the 3D Layer, the user must display a graphical map in the Viewing Window. Users can also display the Lat/Lon Grid Layer, the Groundtrack Layer, the THEMIS Planning Layer or any other layer which draws visible data in the Viewing Window.

2. *Open the 3D Layer*: Chose "Add New Layer" -> "3D Layer"
Select Category:

Home

Subcategories

Map Cartography (2)
- Lat/Lon Grid
- Map Scalebar

Other (7)
- Wind Vectors
- 3D Layer
- Custom Shape Layer
- Nomenclature
- Crater Counting
- Groundtracks
- Mosaic Outlines

Advanced

Close
Dock Me
3D View Window when a 3D layer is added

3. **Navigate in the View**: Using the following mouse and keyboard controls, the user is able to navigate in the 3D Layer's window:
   - Drag Left Mouse Button: Rotate X/Y
   - Shift+Drag Left Mouse Button: Translate X/Y
   - Drag Right Mouse Button: Rotate Z
   - Shift+Drag Right Mouse Button: Zoom
   - Drag Middle Mouse Button: Zoom
   - The W Key: moves the image along the surface upwards.
   - The A Key: moves the image along the surface to the left.
   - The S Key: moves the image downwards.
   - The D Key: moves the image along the surface to the right.
4. *Reset the 3D View*: If the area displayed in the Main View is changed, the area in the 3D View will not automatically change. Clicking the "Reset Camera" button in the 3D Layer focus panel will refresh the 3D View to match the Main View.
5. **Select the map source:** Click the "Set Vertical Source" button to get an additional dialog window. You can select the map you would like to use as your source from the new dialog window. Try using the "Search" area to find your map faster.
Numeric Map Source Selection

Search

Numeric Sources: ○ All  ○ Elevation  ○ Stamp  ○ Custom

Filter: mola

☑ Source Title  □ Abstract/Citation

Search

<table>
<thead>
<tr>
<th>Name</th>
<th>Max PPD</th>
</tr>
</thead>
<tbody>
<tr>
<td>MOLA 128ppd Aspect</td>
<td>128</td>
</tr>
<tr>
<td>MOLA 128ppd Counts</td>
<td>128</td>
</tr>
<tr>
<td><strong>MOLA 128ppd Elevation</strong></td>
<td>128</td>
</tr>
<tr>
<td>MOLA 128ppd Radii</td>
<td>128</td>
</tr>
<tr>
<td>MOLA 128ppd Slope</td>
<td>128</td>
</tr>
<tr>
<td>MOLA 16ppd Areoid</td>
<td>16</td>
</tr>
<tr>
<td>MOLA 256ppd Elevation above 59Å°N</td>
<td>256</td>
</tr>
<tr>
<td>MOLA 256ppd Elevation below -59Å°S</td>
<td>256</td>
</tr>
</tbody>
</table>

Abstract/Citation

This data product is a topographic map of Mars at a resolution of 0.00781 (1/128) by 0.00781 degrees, based on altimetry data acquired by the Mars Global Surveyor MOLA instrument and accumulated over the course of the primary and extended mission. The MOLA Precision Experiment Data Records (PEDRs) are the source for this data set. The map is in the form of a binary table with one row for each 0.00781-degree latitude. Map coordinates use the...
Creating a 3D Printer File

- Once you have your 3D Layer window open with your map source and settings complete, you can export a 3D printer file. Press the "File" menu on the 3D viewer option. Then select "Save 3D Printer File"

- Create a name and location for the file (it saves as an stl file)
Changing the 3D Layer Settings

a. Display the Focus Panel: At the top of the Layer Manager, click on the "3D Viewer" tab.

b. Scene Properties: The scene properties control the appearance of the surface displayed in the 3D Window.

   Bottom: Selecting this option will apply a color to the bottom of the 3D surface in the 3D window. This makes it easier to make sure the user is viewing the top of the surface instead of the bottom.

   Update Scene: If the position of the Main View has changed, click this button to refresh the view displayed in the 3D window.

   Z Scale: This option allows the user to exaggerate the altitudes displayed in the 3D window, which is particularly useful when displaying relatively flat terrain. By default, the elevation (z-axis) has a scaling multiplier of 1.0. To change this value simply change the multiplier and click "Update Scene".

3D view with Z Scale = 2
Altitude: This option allows users to display altitude data from different sources. The default source is the MOLA altitude data.

c. Orientation: This section of the focus panel allows the user to control and modify the view in the "3D View" Window.

d. Directional Light: This section of the focus panel gives users the ability to add an artificial light source to the 3D window in order the change the appearance of shadows on the 3D terrain.

Light On: This check-box will turn on the artificial light source. The default setting is off.

Light Color: This button will give users a color palette from which they can choose the color of the light source.

Light Source Position: The lighted circle represents the position of the artificial light source. By default, the light source is positioned directly above the 3D terrain. To change this position, click on the center of the lighted circle and drag it around the box. Release the click to see what the terrain looks like with the light source in the new position.
Scaling Mode

Under the "Scaling" section at the bottom of the window, you will find a pull down menu, "Mode"

a. **Mode**: After you load the 3D Layer, double click the Layer in the Layer Manager to see the 3D Viewer Options. Under the "Controls" tab you will see a new option, "**Scaling Mode**". There are 3 new options:

   - **Auto Scaling**: Is JMARS way of guessing the appropriate range of the image. Auto scaling automatically scales the data using the radius of Mars. So this option is best used with large ranges of Elevation Change.
   - **Standard Deviation**: Uses the Standard Deviation of the dataset to draw the vertical scaling. If the dataset has a small Standard Deviation, the vertical stretch in the 3D Window will be very small. Best used with the Elevation or Numeric sources.
   - **Range Values**: Uses the Max and Min values and excludes the ignore value of the dataset to draw the vertical scaling. Best used with Elevation and Numeric data. **NOTE**: When using stamps as your elevation source, Zoom in on your main screen to eliminate area that isn't covered by the elevation data.
b. Elevation vs Numeric Data, which option to use:

- Elevation Data: If you are loading data with elevation information, try the **Auto Scale** option first. If this doesn't give you the results you are looking for, try the **Range of Values** option next.

  **NOTE:** When using stamp data as your elevation source, if your stamps have a different range of values, there may be a gap in data. Example below:

![Example](image)

**Example:** A night time IR stamp and a day time IR THEMIS stamp are both loaded. The range of values differ, therefore, causing a gap in data (shown in yellow).

- Numeric Data: If you are loading/using Numeric Data use the **Standard Deviation** option first and then the **Range of Values** option if you don't get the results you want. The **Auto Scaling** option automatically scales using the radius of the selected planetary body, therefore, your results may hardly be noticed if you use this option with numeric data.
Shape Layer

The Shape Layer, which is available in the THEMIS and MRO releases of JMARS, allows users to create and view files containing points and regions of interest. This layer is similar to the Region of Interest (ROI), except that it only allows users to specify geographical regions or locations without observation information and must be saved to a file rather than to a JMARS database.
Open the Shape Layer

1. **Open the Shape Layer**: Chose "Add New Layer" -> "Shapes"
2. **Load a Shape File**: At the top of the Shape Layer focus panel, click "File" -> "Load File". Select the desired shape file and click "Load".
Loading a Shape File

JMARS supports several popular shapefile formats. The restrictions of these formats are described here.

ESRI shapefile

ESRI shapefiles consist of a .shp, .shx, and .dbf file. To load a shapefile in JMARS, go to the File menu in the shape layer, and choose Load, change the file type to Shapefile, and find the .shp file in your file system. Multiple shp files may be selected at one time.

JMARS does not currently support map projected coordinates, x/y/z coordinates, multi-polygons, or polygons with holes in them. Simple shapes with coordinates represented by east longitude and geocentric latitude are required.

CSV

A csv file is a simple comma-separated text file, typically exported from a spreadsheet program like Microsoft Excel. It can represent point data and any number of additional columns of metadata.

When loading a file, the csv reader in JMARS will look for a 'lon' or 'longitude' column, and a 'lat' or 'latitude' column. The usage of these columns is affected by optional header comments, but the default is to interpret the longitude values as degrees east of the prime meridian, and the latitude values as geocentric latitude north of the equator.

Header comments begin with a '#' symbol and should be placed at the top of the csv file. They allow customizing how to interpret the longitude and latitude values.

If the latitude values you are exporting are geographic, you must specify the radii of the datum for JMARS to understand their position on the map. To specify an ellipsoid, the radii must be provided as header keywords. The A/B/C radii keywords are accepted due to their similarity with PDS / ISIS images, but be certain A and B radii are equal. The polar and equatorial radii may also be specified directly as shown below. Both types of radii keywords should not be used. A typical example set of Mars radii:

```
# A_AXIS_RADIUS = 3396.1900000 # B_AXIS_RADIUS = 3396.1900000 # C_AXIS_RADIUS = 3376.2000000
```

OR

```
# EQUAT_RADIUS = 3396.19 # POLAR_RADIUS = 3376.20
```

The default interpretation of longitude values is degrees east of the prime meridian. To specify degrees west of the prime meridian, a header keyword may be added, as shown here:

```
# LONGITUDE_DIRECTION = WEST
```

OR

```
# LON_DIR = W
```

JMARS will attempt to guess the types of all other columns. If a column contains only numbers, it will assume it is a numeric column. If a column contains only 'true' or 'false', it will assume it is a boolean column. All other columns will be loaded into the shape layer as string columns.
Creating a Shape File

1. *Change to Add Mode:* Right-click in the Main View and choose which feature type you would like to add from the list.
2. **Add a Point**: Double-click on the location in the Main View where you want a point located.
   - By default, the point will show up as a white square with a red center. This indicates that it's a stand-alone point and not a corner-point of a polygon.
3. Adding a Polygon: Click on a location in the Main View where you want one of the polygon corners located. Then move to the next corner location and click again. To finish the polygon, click on the first point to close the shape.
   - By default, the polygon will show up as a white outline with a red fill color.
4. **Adding a Polyline**: Click on a location in the Main View where you want to start the line, then move to the next point of the polyline (non-linear line) and single-click to add a new point. When you reach the end, double-click to create the last point.
5. **Saving the Shape File**: At the top of the Shape Layer focus panel, click "Feature" -> "Save All Features As". Specify a location, file name and file type and then click on "Save".
   - For new users, the ESRI file format is recommended.

**Editing a Point/Polygon**

1. **Change to Edit Mode**: Right-click in the Main View and choose "Select Features"
2. **Edit a Point:** Select a point by clicking on it. (It should now be highlighted in yellow.) Left-click on the point and drag it to a new location.
3. **Edit a Polygon**: Select a corner point by clicking on it. (It should now be highlighted in yellow.) To move the corner point, left-click and drag it to a new location. To add a new corner point, left-click on a line, choose "Add Point" and then drag the new point to its final position.

4. **Edit a Polyline**: Similar to editing a polygon, select the line by clicking on it. (It should now be highlighted in yellow.) To move the point, left-click and drag it to a new location. To add a new point, left-click on a line, choose "Add Point" and then drag the new point to its final position.

5. **Re-Save the Shape File**: At the top of the Shape Layer focus panel, click "Features" -> "Save All Features As". Users can either create a new shape file or overwrite the existing shape file.

**Editing the Shape Layer Columns**

- The properties of each object currently loaded in the Shape Layer (points, polylines and polygons) are shown in the "Features" table of the focus panel. By default, the only columns visible are the basic display parameters of each object.

1. **Open the Column Editor**: In the "Shape Layer" focus panel, click the "Adjustment" tab -> "Feature" -> "Edit Columns"
2. **Delete Existing Columns:** All of the existing columns in the focus panel table are displayed in the left-hand box.
   1. **Edit the Shape Layer Settings:** At the bottom of the Shape Layer focus panel, click on "Adjustments" tab -> right click "Feature" -> "Edit Styles" to open the Settings Window.
      - Shape Layer Name: This field allows users to change the name of the shape layer, which will be reflected in the Layer Manager.
Writing Shape Layer Scripts

Users can write simple scripts to automatically edit the parameters of the various features in a shape file, which is especially useful when a file has a large number of features in it. The command language is similar to SQL, but has many differences:

- Color columns are specified by a color_spec (e.g. color(255,255,255) ). The order of the elements in a "color spec" are color( red, green, blue). The colors must be an integer between 0 and 255, inclusive.
- Selecting anything other than the entire row is undefined. Therefore, selection must be preceeded by the string "select rows" or "select *".
- An "update set" query changes the column to the specified value in all the rows selected by the predicate.
- A "move rows" query will move all the rows specified in a where clause by the specified delta.

The following are some basic instructions for getting started. For more information on writing and applying shape layer scripts, read the [Using the Shape Layer tutorial](#).

1. *Open a New Script:* At the top of the Shape Layer focus panel, chose "Scripts" -> "Edit Script". A blank pop-up window will open.
2. *Write a Script*: A script will have three components: an operation, an instruction and a set of rows where the operation will be applied.
   - **Operations**: An SQL-type command such as "update", "select" or "move".
   - **Instructions**: An SQL-type command such as "set[field1]=XXX".
   - **Set of Rows**: An SQL-type specification such as "where field2 like 'XXXXX'"

Examples:

a. **update set [Fill Color]= color(255,255,0) where Label like 'Crater'**
   - changes the fill color to yellow in every row that has a label which consists of the single word "Crater"

b. **update set PERIMETER = AREA + 100**
   - sets the value of the perimeter column to that of the area column plus 100 in all rows

c. **select rows where AREA > 50.00**
   - turns selection on in all the rows where the Area column has a value greater than 50

d. **move rows (0.0, 1.0) where lon > 0**
   - moves all the rows with center longitudes greater than zero 1 degree up
Mosaics Layer

The Mosaics Layer allows users to view regional image mosaics in JMARS. The only mosaics currently available are THEMIS VIS, Day IR and Night IR mosaics, but this will be expanded to include mosaics from other instruments as they become available. Most were originally compiled as part of the various research projects at the Mars Space Flight Facility and are now being made available to a wider audience through JMARS. The Mosaics Layer is available in the Public, THEMIS and MRO releases of JMARS.
Open the Mosaics Layer

1. *Open the Layer*: In the Layer Manager, chose "Add New Layer" - "Mosaic Outlines"
   - Mosaic outlines will be displayed in the Viewing Window.
2. **Load a Mosaic (from the Viewing Window):** In the Viewing Window, right-click on an area covered by a mosaic outline and choose "Load Mosaic_Name"
   - If multiple mosaics cover the selected point, they will all be available as options in the right-click menu.
   - After a mosaic is loaded, it will appear as a separate layer in the Layer Manager.
3. **Load a Mosaic (from the Focus Panel):** Double click on the "Mosaics" tab in the Layer Manager to access the focus panel, which contains a sortable list of all the available mosaics. Right-clicking on a mosaic name gives a user the option to either center the Viewing Window on the mosaic or load the mosaic.
4. **Remove a Mosaic**: To remove a specific mosaic from your JMARS session, highlight the mosaic or layer name, click "Edit Selected" and then select "Delete".
Map Layer

The Map Layer allows users to load and display global maps of Mars and other planetary bodies. All versions of JMARS include the Map Layer, which offers users two options: Graphic/Numeric Maps and Advanced/Custom Maps.
- Numeric data can be added by clicking the home tab, then selecting either "Instrument" or "Imagery". In this example, we click on Instrument.

- Any of the subcategories can be selected. Here, we selected MOLA data.

- Finally, the user can select the data. In this example we selected MOLA Colorized Elevation.